Having trouble logging in? Password not accepted? Recently some bad apples caused a bit of a ruckus around here and a few accounts had to be reset.
Please, drop Toshiba, Errol or n3wton a line and they'll sort you right out! We apologise for any inconvenience this may cause :(

A work around for compiling models
Spectre2011 created A work around for compiling models on Mon Dec 29, 2014 3:25 am
Hi I posted this in the noobs section, because Cared refuses to work due to fantastic improving technology (HAHAHAHAHA!!!!) I would like to know if there is a way I could compile c2 things manually. I tried bemax but it does blender models funky to me, and I tried asc2ase but it requires me to use 3ds max, which I only have the old one.
Sorry for any foolishness in advance.
User avatar
coffeycup on Mon Dec 29, 2014 4:02 pm
If you're using Blender then I think you'll need to stick with ASC2ASE and PT2. It's ok if you only have an old version of 3DSMax as you're only using it to convert a 3DS (or whatever Blender exports) to an ASC right?

I use SketchUp so I'm in the same boat as you. I export a 3DS from SketchUp. Import the 3DS into 3DSMax just to export an ASC. Then use ASC2ASE to get an ASE I can import into PT2.
MacCarpocalypse | coffey.polygonized.com | CoffeyCup's Gallery
Spectre2011 on Tue Dec 30, 2014 5:16 pm
Thanks for the info, hey uh I'm having an issue with ase2asc, when I import it to cesm's plaything2 it loads blank.
User avatar
coffeycup on Tue Dec 30, 2014 10:14 pm
Did ASC2ASE give a success message after it ran?
Are you sure it's blank, i.e. nothing in the hierarchy?
Or is it scaled really big and out of view?
MacCarpocalypse | coffey.polygonized.com | CoffeyCup's Gallery
User avatar
Deep_Blue on Tue Dec 30, 2014 11:48 pm
Or is it blank like everythjng is black?

Seems the 1.2.3 or whatever latest version of ase2asc does strange things with colors and textures. It gave me hella problems until I got version 1.1.3 and then 1.1.4. Those work no prob. (If that's the trouble yer having...)
***When I die may I be surrounded by scattered chrome and burning gasoline***
Spectre2011 on Wed Dec 31, 2014 1:41 am
It's blank, nothing is there, not even an error. but I have a clue to some things.
I get a success message, but it says "some parts were ignored"
and when I put a 3ds from blender into 3dsmax2 it shows up distorted in the 3d window.
oh yeah, and I dont texture it before I put it in ase2asc.
User avatar
coffeycup on Wed Dec 31, 2014 2:27 pm
I get the 'some parts were ignored' message too, that's not a big deal. But the 3DS being distorted in 3DSMax is not good because that's what will be exported.

Why aren't you texturing the model in Blender? I know you can texture in PT2 but it's a real pain in the ass. You really should be exporting finished, fully textured models so you're just doing the setup in PT2.
MacCarpocalypse | coffey.polygonized.com | CoffeyCup's Gallery
Spectre2011 on Wed Dec 31, 2014 6:22 pm
Alright I get too eager with my test models, thats why I texture late,
I'll export finished this time, dont know what I'm going to do to get 3dsmax2 to have regular shapes rather than what its doing now.
User avatar
coffeycup on Wed Dec 31, 2014 6:46 pm
Well, if you're just running tests then untextured is ok I guess.
When you say model is distorted is is squished along one axis? Maybe post a screenshot so we can see issue?
MacCarpocalypse | coffey.polygonized.com | CoffeyCup's Gallery
Spectre2011 on Thu Jan 01, 2015 7:23 pm


20mb image hosting

I modelled a box car and subsurf'd it
then 3ds max turns it into that.
note: whats odd is if I use bemax to compile, visually the model does looks just right in plaything, then I take a look and compare dat file of other cars in a hex editor, bemax tends to do dat files a little different, and weirdly enough even when I get plaything to setup car, the dat looks the same in the hex editor. I need to try it again.
Edit. expiremented with it again, it failed horribly.
User avatar
coffeycup on Thu Jan 01, 2015 8:16 pm
So top picture is from Blender and what it should look like, yes? In 3DSMax it flips body 90'? Are the tires supposed to be that wide or are they getting messed with too? The tires at least look like they're in the correct position.

I don't know how models are setup in Blender so I don't know if this is helpful but when I export a 3DS from SketchUp I will ungroup the object that will be the master object, usually the body or chassis. I'll leave the detachables like doors, bonnet, bumpers etc. as individual groups.

I think I started doing that because I was getting an error message that the all objects were empty when I imported into PT2. There needed to be at least one that wasn't grouped, at least that's what it seemed like to me. :confused:
MacCarpocalypse | coffey.polygonized.com | CoffeyCup's Gallery
Spectre2011 on Thu Jan 01, 2015 10:24 pm
well the first pic I had to flip it back just to show you how it looks like on the road, before I export it I flip the pitch up 90 degrees for the carma axis.
and when it goes in 3ds max, the front and back get squished.
I dunno All this seems like a silly fluke, and probably a grouping issue.

I'll probably have to try other modellers.
yes the tires are that wide in the car. :P
EDIT (again): just to let you know also, I used one component in the whole model, and ase2asc likes to skip it, maybe thats my problem...right?
Spectre2011 on Mon Jan 05, 2015 1:12 am
I'm getting 3ds max 8 and carmatools from cesm, all these converting issues will be over.
seriously I actually tried the carmatools, it made my giant block car work when I was messing around with the free trial. :)
Pages: 1

Extra information
It is currently Sat Mar 23, 2019 9:51 am,

Please Register a username.
In total there are 4 users online :: 0 registered, 0 hidden and 4 guests
Users browsing this forum: No registered users and 4 guests
Moderator: coffeycup

Powered by phpBB :: Hosted by n3wton :: Molested by goats
CWA Links